Blender Git Statistics -> Branches -> viewport_experiments

"Viewport_experiments" branch

Total commits : 114
Total committers : 2
First Commit : September 12, 2014
Latest Commit : February 12, 2015


Commits by Month

DateNumber of Commits
February, 201529
January, 201521
December, 20145
November, 201417
October, 201427
September, 201415

Committers

AuthorNumber of Commits
Antony Riakiotakis106
Campbell Barton8

Popular Files

FilenameTotal Edits
gpu_compositing.c53
space_view3d.py27
gpu_extensions.c23
view3d_draw.c21
DNA_gpu_types.h20
DNA_view3d_types.h19
GPU_compositing.h17
rna_space.c17
gpu_shader_fx_dof_frag.glsl16
gpu_shader_fx_frag.glsl15

Latest commits Feed

February 12, 2015, 17:45 (GMT)
Final nitpicks:

No warning for out of camera, rename darken to factor/strength (since
color can be actually be light)
February 12, 2015, 17:43 (GMT)
replace 'SSAO' option with 'Ambient Occlusion'

more descriptive, and SSAO is more for developers/shader writers
February 12, 2015, 17:40 (GMT)
error in last commit
February 12, 2015, 17:38 (GMT)
use common GPU_fx_compositor_ prefix

also rename darkening -> darken
February 12, 2015, 17:36 (GMT)
Tidy up the UI a bit for DOF
February 12, 2015, 17:26 (GMT)
Add initialization functions for GPU compositing
February 12, 2015, 17:21 (GMT)
move comment to view3d
February 12, 2015, 17:19 (GMT)
correction to last comment
February 12, 2015, 17:18 (GMT)
Comment out DOF initialization, its not used

This is a special case
February 12, 2015, 17:15 (GMT)
Also write DOF if it exists.
February 12, 2015, 17:09 (GMT)
Move fx_flag into the GPUFXSettings struct (simplifies things a bit)
February 12, 2015, 16:36 (GMT)
Various changes:

- use term 'settings' rather then 'options', (follows rest of rna)
- use const where possible
- minor changes to arg order
February 12, 2015, 15:19 (GMT)
Merge branch 'master' into viewport_master_merge
February 12, 2015, 15:18 (GMT)
3D Viewport only uses DOF when rendered from camera now.
February 12, 2015, 14:43 (GMT)
Reuse focal length and sensor from camera
February 12, 2015, 14:38 (GMT)
More naming tidying up
February 12, 2015, 14:12 (GMT)
Don't allocate FX, naming of eGPUFXFlags
February 12, 2015, 13:54 (GMT)
Cleanup naming, use sane defaults
February 10, 2015, 16:32 (GMT)
Minor simplification
February 10, 2015, 15:45 (GMT)
Cleanup redundant state changes

MiikaHweb - Blender Git Statistics v1.06
By: Miika HämäläinenLast update: Nov-07-2014 14:18 MiikaHweb | 2003-2019