Blender Git Commits

Blender Git "viewport_experiments" branch commits.

February 12, 2015, 17:45 (GMT)
Final nitpicks:

No warning for out of camera, rename darken to factor/strength (since
color can be actually be light)
February 12, 2015, 17:43 (GMT)
replace 'SSAO' option with 'Ambient Occlusion'

more descriptive, and SSAO is more for developers/shader writers
February 12, 2015, 17:40 (GMT)
error in last commit
February 12, 2015, 17:38 (GMT)
use common GPU_fx_compositor_ prefix

also rename darkening -> darken
February 12, 2015, 17:36 (GMT)
Tidy up the UI a bit for DOF
February 12, 2015, 17:26 (GMT)
Add initialization functions for GPU compositing
February 12, 2015, 17:21 (GMT)
move comment to view3d
February 12, 2015, 17:19 (GMT)
correction to last comment
February 12, 2015, 17:18 (GMT)
Comment out DOF initialization, its not used

This is a special case
February 12, 2015, 17:15 (GMT)
Also write DOF if it exists.
February 12, 2015, 17:09 (GMT)
Move fx_flag into the GPUFXSettings struct (simplifies things a bit)
February 12, 2015, 16:36 (GMT)
Various changes:

- use term 'settings' rather then 'options', (follows rest of rna)
- use const where possible
- minor changes to arg order
February 12, 2015, 15:19 (GMT)
Merge branch 'master' into viewport_master_merge
February 12, 2015, 15:18 (GMT)
3D Viewport only uses DOF when rendered from camera now.
February 12, 2015, 14:43 (GMT)
Reuse focal length and sensor from camera
February 12, 2015, 14:38 (GMT)
More naming tidying up
February 12, 2015, 14:12 (GMT)
Don't allocate FX, naming of eGPUFXFlags
February 12, 2015, 13:54 (GMT)
Cleanup naming, use sane defaults
February 10, 2015, 16:32 (GMT)
Minor simplification
February 10, 2015, 15:45 (GMT)
Cleanup redundant state changes
By: Miika HämäläinenLast update: Nov-07-2014 14:18 MiikaHweb | 2003-2020